banner
SSH

Membuat Banner Login SSH

banner

Para penjual SSH, yg mw akses nya terlihat lebih premium, bisa gunain fitur ini. keren klo pas lagi login bitvise ada banner ” Haloooo..”😀

nano /etc/ssh/sshd-banner

Isi dengan kalimat terserah keinginan atau bisa memakai contoh ini

“Premium SSH” oleh ibolobolo

Lalu Buka setingan SSH dan tambkan setingan berikut

nano /etc/ssh/sshd_config
Banner /etc/ssh/sshd-banner
Save dan restart ssh server

service sshd restart

Standard
o8
Juniper, Networking

JunOS on GSN3

First, Download the image   –> https://kickass.to/junos-binary-image-ready-for-qemu-gns3-t7523827.html

Open GNS3 – Edit -Prefrences – Qemu -JunOS.

j1

Save and aply – OK.

Next Start GNS3. wait for 10 minutes. Nex your root ass username no password. type “cli” to enter junOS config.

o8

 

Standard
SquidProxyMikrotik
Linux, Networking, Server

Squid Mikrotik Transparent

Waktu tu sempet diajarin di LAB. tapi penggunaan real nya gk paham banget. apa mungkin gw yg terlalu Bego / ast. lab nya terlalu pinter ngajar nya . hanya mereka yg tahu :-p

  1.  install Squid nya di Linux.
  2. Ready Mikrotik konek ke Linux nya
  3.  Client.

Topologi yg gw pake.

|Centos | ———- | Mikrotik| ——–| winxp|

Konfig

Winbox IP > Web Proxy > Setting

port =3128 ( bedakan portnya dengan port squid )

tranparent proxy dikasi tanda centang

parent proxy = ipsquid

parent proxy port = 3128

cache administrator =sukasukaLO

maximum cache size = default aja

click enable kalo dibagian bawah udah ada tulisan “running” artinya web proxy mikrotik udah jalan

Setting NAT di Mikrotik

via Winbox

IP > Firewall > NAT

Pada tab General

Click tanda +

masukan data – data sbb

chain = dstnat

src address = ip local squid

centang  kotak kecil sebelah kiri.

protocol = 6 (tcp)

dst port = 80

Pada tab Action

action = redirect

port = 3128 ( port web proxy mikrotik )

SquidProxyMikrotik

Standard
gns
Cisco, Linux, Networking, Server

Kolaborasi RIP Cisco dan Mikrotik

gns

Bahan-bahan nya:

  • GNS3. (ready hypervisor)
  • Virtual Box.

Adapter yg di pake di Vbox.

XP: internal (name intA)

Centos: Internal (name intaB

Mikrotik: Host only adapters, Internal (intA dan intB) dan NAT.

internal A dan B network nya beda. dan meraka masing ternoneksi ke internal nya mikrotik. Host Only adapter nya konek ke Cisco, Cico punya 2 interface yang 1 nya nyambung ke mikrotik lwt vbox adapter, satunya lagi ke xp nyambung ke vbox adapter.

nb: Switch itu pajangan doang!

Configurasi.

  • Set IP cisco dan mikrotik. (search aja)
  • Set RIP cisco dan Mikrotik.
  • Set NAT. biar mikrotik bisa inetan.

Sumber koneksi inetan dari USB tehthering Android🙂

Konfigurasi RIP di Mikrotik.

Gampang men! (sampe sini udah harus set semua ip, mulai dr cisco smpe mikrotik dan juga client)

  1. Masuk pake winbox.
  2. Menu Routing — Tab Network. (set rip, sama kayak set RIP cisco, gak jauh beda)

rip#this is my note aka my little brain, may be only me can understand

note:  Total Network ada 4, Total ip ada 8. Colusion di windows karna tethering 😡

Standard
SDM
Campus, Cisco, Networking, Server

Configure Security Device Manager – on Cisco Router.

Apa itu Security Device Manager, di Search aja yaaa…

SDM

Topologi nya:

topologi

Config di sisi router:

# Set Ip address Router juga PC nya, dalam 1 network. klo di ping gk RTO lah.

Step 1 Aktifin HTTP/HTTPS Server di Router nya.

Router(config)# ip http server

Router(config)# ip http secure-server

Router(config)# ip http authentication local

Step 2 Buat User Dengan privilege 15.

Router(config)# username <username> privilege 15 password 0 <password>

Step 3 Configure SSH and Telnet for local login and privilege level 15:

Router(config)# line vty 0 4

Router(config-line)# privilege level 15
Router(config-line)# login local

Router(config-line)# transport input telnet

Router(config-line)# transport input telnet ssh

Router(config-line)# exit

####Install SDM nya####
Program SDM, di Search aja gan di Google.




Hasil nya.... Eng..ing...eng..............
SDM
Standard
index
Cisco, Networking

Redistribute Routing Protocol ( Static, RIP, OSPF dan EIGRP )

Topologi

Skenario :

Router Interface Address Network Broadcast
ISP fastEthernet 0/1 111.111.111.1/30 111.111.111.0/30 111.111.111.3/30
  fastEthernet 0/0 111.111.111.5/30 111.111.111.4/30 111.111.111.7/30
HQ fastEthernet 0/0 10.0.0.1/30 10.0.0.0/30 10.0.0.3/30
  fastEthernet 0/1 10.0.0.13/30 10.0.0.12/30 10.0.0.15/30
  fastEthernet 1/0 10.0.0.45/30 10.0.0.44/30 10.0.0.47/30
  fastEthernet 1/1 10.0.0.33/30 10.0.0.32/30 10.0.0.35/30
  ethernet 0/0/0 111.111.111.6/30 111.111.111.4/30 111.111.111.7/30
  ethernet 0/2/0 10.0.0.25/29 10.0.0.24/30 10.0.0.31/30
loopback 0 10.0.0.60/32
Static_1 fastEthernet 0/1 10.0.0.2/30 10.0.0.0/30 10.0.0.3/30
fastEthernet 0/0 10.0.0.5/30 10.0.0.4/30 10.0.0.7/30
Static_2 fastEthernet 0/1 10.0.0.6/30 10.0.0.4/30 10.0.0.7/30
fastEthernet 0/0 10.0.0.9/30 10.0.0.8/30 10.0.0.11/30
Static_3 fastEthernet 0/0 10.0.0.10/30 10.0.0.8/30 10.0.0.11/30
fastEthernet 0/1 10.0.1.129/27 10.0.1.128/27 10.0.1.163/27
Rip_1 fastEthernet 0/0 10.0.0.14/30 10.0.0.12/30 10.0.0.15/30
fastEthernet 0/1 10.0.0.17/30 10.0.0.16/30 10.0.0.19/30
Rip_2 fastEthernet 0/0 10.0.0.18/30 10.0.0.16/30 10.0.0.19/30
fastEthernet 0/1 10.0.0.21/30 10.0.0.20/30 10.0.0.23/30
Rip_3 fastEthernet 0/0 10.0.0.22/30 10.0.0.20/30 10.0.0.23/30
fastEthernet 0/1 10.0.1.1/25 10.0.1.0/25 10.0.1.127/25
Ospf_1 fastEthernet 0/0 10.0.0.34/30 10.0.0.32/30 10.0.0.35/30
  fastEthernet 0/1 10.0.0.37/30 10.0.0.36/30 10.0.0.39/30
loopback 0 10.0.0.57/32
Ospf_2 fastEthernet 0/0 10.0.0.38/32 10.0.0.36/30 10.0.0.39/30
  fastEthernet 0/1 10.0.0.41/32 10.0.0.40/30 10.0.0.43/30
loopback 0 10.0.0.58/32
Ospf_3 fastEthernet 0/0 10.0.0.42/30 10.0.0.40/30 10.0.0.43/30
  fastEthernet 0/1 10.0.0.129/25 10.0.0.128/30 10.0.0.163/30
loopback 0 10.0.0.59/32
Eigrp_1 fastEthernet 0/0 10.0.0.46/30 10.0.0.44/30 10.0.0.47/30
fastEthernet 0/1 10.0.0.49/30 10.0.0.48/30 10.0.0.51/30
Eigrp_2 fastEthernet 0/0 10.0.0.50/30 10.0.0.48/30 10.0.0.51/30
fastEthernet 0/1 10.0.0.53/30 10.0.0.52/30 10.0.0.55/30
Eigrp_3 fastEthernet 0/0 10.0.0.54/30 10.0.0.452/30 10.0.0.55/30
  fastEthernet 0/1 10.0.0.65/26 10.0.0.64/26 10.0.0.127/26

Configuration :

Router Static_1

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname Static_1

Static_1(config)#interface fastEthernet 0/1

Static_1(config-if)#no shutdown

Static_1(config-if)#ip address 10.0.0.2 255.255.255.252

Static_1(config-if)#exit

Static_1(config)#interface fastEthernet 0/0

Static_1(config-if)#no shutdown

Static_1(config-if)#ip address 10.0.0.5 255.255.255.252

Static_1(config-if)#exit

Static_1(config)#ip route 10.0.0.8 255.255.255.252 10.0.0.6

Static_1(config)#ip route 10.0.1.128 255.255.255.224 10.0.0.10

Static_1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1

Static_1(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Static_1#^Z

Static_1#wr mem

Building configuration…

[OK]

Static_1#

Router Static_2

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname Static_2

Static_2(config)#interface fastEthernet 0/0

Static_2(config-if)#no shutdown

Static_2(config-if)#ip address 10.0.0.9 255.255.255.252

Static_2(config-if)#exit

Static_2(config)#interface fastEthernet 0/1

Static_2(config-if)#ip address 10.0.0.6 255.255.255.252

Static_2(config-if)#exit

Static_2(config)#ip route 10.0.0.0 255.255.255.252 10.0.0.

Static_2(config)#ip route 10.0.1.128 255.255.255.224 10.0.0.10

Static_2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.5

Static_2(config)#exit

Static_2#

%SYS-5-CONFIG_I: Configured from console by console

Static_2#wr mem

Building configuration…

[OK]

Static_2#

Router Static_3

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname Static_3

Static_3(config)#interface fastEthernet 0/0

Static_3(config-if)#no shutdown

Static_3(config-if)#ip address 10.0.0.10 255.255.255.252

Static_3(config-if)#exit

Static_3(config)#interface fastEthernet 0/1

Static_3(config-if)#no shutdown

Static_3(config-if)#ip address 10.0.1.129 255.255.255.224

Static_3(config-if)#exit

Static_3(config)#ip dhcp po

Static_3(config)#ip dhcp pool Static_3

Static_3(dhcp-config)#default-router 10.0.1.129

Static_3(dhcp-config)#network 10.0.1.128 255.255.255.224

Static_3(dhcp-config)#dns-server 10.0.0.30

Static_3(dhcp-config)#exit

Static_3(config)#ip route 10.0.0.0 255.255.255.252 10.0.0.5

Static_3(config)#ip route 10.0.0.4 255.255.255.252 10.0.0.9

Static_3(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.9

Static_3(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Static_3#wr mem

Building configuration…

[OK]

Static_3#

Router RIP_1

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RIP_1

RIP_1(config)#interface fastEthernet 0/0

RIP_1(config-if)#no shutdown

RIP_1(config-if)#ip address 10.0.0.14 255.255.255.252

RIP_1(config-if)#exit

RIP_1(config)#interface fastEthernet 0/1

RIP_1(config-if)#no shutdown

RIP_1(config-if)#ip address 10.0.0.17 255.255.255.252

RIP_1(config-if)#exit

RIP_1(config)#router rip

RIP_1(config-router)#version 2

RIP_1(config-router)#network 10.0.0.12

RIP_1(config-router)#network 10.0.0.16

RIP_1(config-router)#exit

RIP_1(config-router)#ip route 0.0.0.0 0.0.0.0 10.0.0.13

RIP_1(config)#exit

RIP_1#

%SYS-5-CONFIG_I: Configured from console by console

RIP_1#wr mem

Building configuration…

[OK]

RIP_1#

Router RIP_2

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RIP_2

RIP_2(config)#interface fas

RIP_2(config)#interface fastEthernet 0/0

RIP_2(config-if)#no shutdown

RIP_2(config-if)#ip address 10.0.0.18 255.255.255.252

RIP_2(config-if)#exit

RIP_2(config)#interface fastEthernet 0/1

RIP_2(config-if)#no shutdown

RIP_2(config-if)#ip address 10.0.0.21 255.255.255.252

RIP_2(config-if)#exit

RIP_2(config)#router rip

RIP_2(config-router)#version 2

RIP_2(config-router)#network 10.0.0.16

RIP_2(config-router)#network 10.0.0.20

RIP_2(config-router)#exit

RIP_2(config-router)# ip route 0.0.0.0 0.0.0.0 10.0.0.17

RIP_2(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

RIP_2#

RIP_2#wr mem

Building configuration…

[OK]

RIP_2#

Router RIP_3

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RIP_3

RIP_3(config)#interface fastEthernet 0/0

RIP_3(config-if)#no shutdown

RIP_3(config-if)#ip address 10.0.0.22 255.255.255.252

RIP_3(config-if)#exit

RIP_3(config)#interface fastEthernet 0/1

RIP_3(config-if)#no shutdown

RIP_3(config-if)#ip address 10.0.1.1 255.255.255.128

RIP_3(config-if)#exit

RIP_3(config)#ip dhcp pool RIP_3

RIP_3(dhcp-config)#default-router 10.0.1.1

RIP_3(dhcp-config)#network 10.0.1.0 255.255.255.128

RIP_3(dhcp-config)#dns-server 10.0.0.30

RIP_3(dhcp-config)#exit

RIP_3(config)#router rip

RIP_3(config-router)#version 2

RIP_3(config-router)#network 10.0.0.20

RIP_3(config-router)#network 10.0.1.0

RIP_3(config-router)#exit

RIP_3(config-if)# ip route 0.0.0.0 0.0.0.0 10.0.0.21

RIP_3(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

RIP_3#

RIP_3#wr mem

Building configuration…

[OK]

RIP_3#

 

 

 

Router OSPF_1

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname OSPF_1

OSPF_1(config)#interface fastEthernet 0/0

OSPF_1(config-if)#no shutdown

OSPF_1(config-if)#ip address 10.0.0.34 255.255.255.252

OSPF_1(config-if)#exit

OSPF_1(config)#interface fastEthernet 0/1

OSPF_1(config-if)#ip address 10.0.0.37 255.255.255.252

OSPF_1(config-if)#no shutdown

OSPF_1(config-if)#exit

OSPF_1(config)#interface loopback 0

OSPF_1(config-if)#ip address 10.0.0.57 255.255.255.255

OSPF_1(config-if)#exit

OSPF_1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.33

OSPF_1(config)#router ospf 1

OSPF_1(config-router)#network 10.0.0.32 0.0.0.3 area 0

OSPF_1(config-router)#network 10.0.0.36 0.0.0.3 area 0

OSPF_1(config-router)#log-adjacency-changes

OSPF_1(config-router)#router-id 10.0.0.56

OSPF_1(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

OSPF_1(config-router)#exit

OSPF_1(config)#^Z

OSPF_1#

%SYS-5-CONFIG_I: Configured from console by console

OSPF_1#wr mem

Building configuration…

[OK]

OSPF_1#

Router OSPF_2

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hos

Router(config)#hostname OSPF_2

OSPF_2(config)#interface fastEthernet 0/0

OSPF_2(config-if)#no shutdown

OSPF_2(config-if)#ip address 10.0.0.38 255.255.255.252

OSPF_2(config-if)#exit

OSPF_2(config)#interface fastEthernet 0/1

OSPF_2(config-if)#no shutdown

OSPF_2(config-if)#ip address 10.0.0.41 255.255.255.252

OSPF_2(config-if)#exit

OSPF_2(config)#interface loopback 0

OSPF_2(config-if)#ip address 10.0.0.58 255.255.255.255

OSPF_2(config-if)#exit

OSPF_2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.37

OSPF_2(config)#router ospf 1

OSPF_2(config-router)#network 10.0.0.36 0.0.0.3 area 0

OSPF_2(config-router)#network 10.0.0.40 0.0.0.3 area 0

OSPF_2(config-router)#log-adjacency-changes

OSPF_2(config-router)#router-id 10.0.0.57

OSPF_2(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

OSPF_2(config-router)#exit

OSPF_2(config)#^Z

OSPF_2#

%SYS-5-CONFIG_I: Configured from console by console

OSPF_2#wr mem

Building configuration…

[OK]

OSPF_2#

Router OSPF_3

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname OSPF_3

OSPF_3(config)#interface fastEthernet 0/0

OSPF_3(config-if)#no shutdown

OSPF_3(config-if)#ip address 10.0.0.42 255.255.255.252

OSPF_3(config-if)#exit

OSPF_3(config)#interface loopback 0

OSPF_3(config-if)#ip address 10.0.0.59 255.255.255.255

OSPF_3(config-if)#exit

OSPF_3(config)#interface fastEthernet 0/1

OSPF_3(config-if)#no shutdown

OSPF_3(config-if)#ip address 10.0.0.129 255.255.255.128

OSPF_3(config-if)#exit

OSPF_3(config)#ip dhcp pool ospf_3

OSPF_3(dhcp-config)#default-router 10.0.0.129

OSPF_3(dhcp-config)#network 10.0.0.128 255.255.255.128

OSPF_3(dhcp-config)#dns-server 10.0.0.30

OSPF_3(dhcp-config)#exit

OSPF_3(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.41

OSPF_3(config)#router ospf 1.

OSPF_3(config-router)#network 10.0.0.40 0.0.0.3 area 0

OSPF_3(config-router)#network 10.0.0.129 0.0.0.127 area 0

OSPF_3(config-router)#router-id 10.0.0.58

OSPF_3(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

OSPF_3(config-router)#exit

OSPF_3(config)#exit

OSPF_3#

%SYS-5-CONFIG_I: Configured from console by console

OSPF_3#wr mem

Building configuration…

[OK]

OSPF_3#

EIGRP_1

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname EIGRP_1

EIGRP_1(config)#interface fastEthernet 0/0

EIGRP_1(config-if)#no shutdown

EIGRP_1(config-if)#ip address 10.0.0.46 255.255.255.252

EIGRP_1(config-if)#exit

EIGRP_1(config)#interface fastEthernet 0/1

EIGRP_1(config-if)#no shutdown

EIGRP_1(config-if)#ip address 10.0.0.49 255.255.255.252

EIGRP_1(config-if)#exit

EIGRP_1(config-if)#ip route 0.0.0.0 0.0.0.0 10.0.0.45

EIGRP_1(config)#router eigrp 1

EIGRP_1(config-router)#network 10.0.0.44 0.0.0.3

EIGRP_1(config-router)#network 10.0.0.48 0.0.0.3

EIGRP_1(config-router)#exit

EIGRP_1(config)#exit

EIGRP_1#

%SYS-5-CONFIG_I: Configured from console by console

EIGRP_1#wr mem

Building configuration…

[OK]

EIGRP_1#

EIGRP_2

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname EIGRP_2

EIGRP_2(config)#interface fastEthernet 0/0

EIGRP_2(config-if)#no shutdown

EIGRP_2(config-if)#ip address 10.0.0.50 255.255.255.252

EIGRP_2(config-if)#exit

EIGRP_2(config)#interface fastEthernet 0/1

EIGRP_2(config-if)#no shutdown

EIGRP_2(config-if)#ip address 10.0.0.53 255.255.255.252

EIGRP_2(config-if)#exit

EIGRP_1(config-if)#ip route 0.0.0.0 0.0.0.0 10.0.0.49

EIGRP_2(config)#router eigrp 1

EIGRP_2(config-router)#network 10.0.0.48 0.0.0.3

EIGRP_2(config-router)#network 10.0.0.52 0.0.0.3

EIGRP_2(config-router)#exit

EIGRP_2(config)#exit

EIGRP_2#

%SYS-5-CONFIG_I: Configured from console by console

EIGRP_2#w mem

Building configuration…

[OK]

EIGRP_2#

EIGRP_3

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hos

Router(config)#hostname EIGRP_3

EIGRP_3(config)#interface fastEthernet 0/0

EIGRP_3(config-if)#no shutdown

EIGRP_3(config-if)#ip address 10.0.0.54 255.255.255.252

EIGRP_3(config-if)#exit

EIGRP_3(config)#interface fastEthernet 0/1

EIGRP_3(config-if)#no shutdown

EIGRP_3(config-if)#ip address 10.0.0.65 255.255.255.192

EIGRP_3(config-if)#exit

EIGRP_3(config-if)# ip route 0.0.0.0 0.0.0.0 10.0.0.53

EIGRP_3(config)#ip dhcp pool eigrp_3

EIGRP_3(dhcp-config)#default-router 10.0.0.65

EIGRP_3(dhcp-config)#network 10.0.0.64 255.255.255.192

EIGRP_3(dhcp-config)#dns-server 10.0.0.30

EIGRP_3(dhcp-config)#exit

EIGRP_3(config)#router eigrp 1

EIGRP_3(config-router)#network 10.0.0.52 0.0.0.3

EIGRP_3(config-router)#network 10.0.0.64 0.0.0.63

EIGRP_3(config-router)#exit

EIGRP_3(config)#^Z

EIGRP_3#

%SYS-5-CONFIG_I: Configured from console by console

EIGRP_3#wr mem

Building configuration…

[OK]

EIGRP_3#

Router HQ

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname HQ

HQ(config)#interface fastEthernet 0/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.1 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface fastEthernet 0/1

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.13 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface ethernet 0/2/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.25 255.255.255.248

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface fastEthernet 1/1

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.33 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface fastEthernet 1/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.45 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface ethernet 0/0/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 111.111.111.6 255.255.255.252

HQ(config-if)#ip nat outside

HQ(config-if)#exit

HQ(config)#interface loopback 0

HQ(config-if)#ip address 10.0.0.60 255.255.255.255

HQ(config-if)#exit

HQ(config)#ip route 10.0.0.4 255.255.255.252 10.0.0.2

HQ(config)#ip route 10.0.0.8 255.255.255.252 10.0.0.6

HQ(config)#ip route 10.0.1.128 255.255.255.224 10.0.0.10

HQ(config)#ip route 0.0.0.0 0.0.0.0 111.111.111.5

HQ(config)#ip nat inside source list 1 interface ethernet 0/0/0 overload

HQ(config)#access-list 1 permit any

HQ(config)#ip nat inside source static 10.0.0.29 111.111.111.6

HQ(config)#router rip

HQ(config-router)#version 2

HQ(config-router)#network 10.0.0.12

HQ(config-router)#redistribute eigrp 1 metric 1

HQ(config-router)#redistribute ospf 1 metric 1

HQ(config-router)#redistribute static metric 1

HQ(config-router)#exit

HQ(config)#router ospf 1

HQ(config-router)#network 10.0.0.32 0.0.0.3 area 0

HQ(config-router)#log-adjacency-changes

HQ(config-router)#router-id 10.0.0.59

HQ(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

HQ(config-router)# redistribute rip subnets

HQ(config-router)# redistribute eigrp 1 subnets

HQ(config-router)# redistribute static metric 1 subnets

HQ(config-router)#exit

HQ(config)#router eigrp 1

HQ(config-router)#network 10.0.0.44 0.0.0.3

HQ(config-router)#network 10.0.0.24 0.0.0.7

HQ(config-router)#redistribute rip metric 1 1 1 1 1

HQ(config-router)#redistribute ospf 1 metric 1 1 1 1 1

HQ(config-router)# redistribute static

HQ(config-router)#exit

HQ(config)#ex

HQ#

%SYS-5-CONFIG_I: Configured from console by console

HQ#wr mem

Building configuration…

[OK]

HQ#

Router_ISP

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname ISP

ISP(config)#interface fastEthernet 0/0

ISP(config-if)#no shutdown

ISP(config-if)#ip address 111.111.111.5 255.255.255.252

ISP(config-if)#exit

ISP(config)#interface fastEthernet 0/1

ISP(config-if)#no shutdown

ISP(config-if)#ip address 111.111.111.1 255.255.255.252

ISP(config-if)#exit

ISP(config)# ip route 0.0.0.0 0.0.0.0 111.111.111.6

ISP(config)#^Z

ISP#

%SYS-5-CONFIG_I: Configured from console by console

ISP#wr mem

Building configuration…

[OK]

Standard
ssh
Linux, Networking, Server

Membuat SSH tunnel server pada CentOS.

Tasted by ibolobolo.

ssh

ssh1

#Siapin CentOS #Install OpenSSH (yum install openssh)

Config pada centos

$ssh -D 9999 username@alamat-ssh-server

$ssh -D 9123 van@server.ssh.com

Masukkan password account anda pada server SSH tersebut. Lalu komputer anda akan membuat SOCKS Proxy pada port “9123″. Biarkan koneksi ini terus terbuka, dan jangan di tutup!

Kemudian kita akan seting browser kita agar menggunakan proxy lokal yang telah kita buat.
Pada Firefox, masuk ke “Edit => Preferences”
Pada Tab “Advanced” pilih “Network” lalu klik “Settings” pada kolom “Connection”
Pilih “Manual Proxy Configuration” dan isikan “localhost” pada kolom “SOCKS Host” dan pada “Port” isikan port yang telah kita buat, dalam contoh ini adalah “9123″

Tutup jendela konfigurasi network firefox anda. kemudian cobalah browsing seperti biasa. Jika tunneling kita berhasil, maka akan terasa perbedaan kecepatan nya. Apalagi jika server terletak di jaringan IIX dan mempunyai bandwith yang sangat besar.
Jika tidak, cobalah cari SSH server lain yang terletak di jalur IIX dan punya koneksi sangat kencang (Tidak akan saya jelaskan, dan jangan tanya).
Atau anda juga bisa membuat tunneling sendiri pada jaringan di kantor atau Instansi anda. Mungkin ada komputer lain yang koneksinya lebih kencang dan maknyus dari yang anda gunakan. Tinggal isikan IP Address dari komputer tersebut. Yah dengan syarat, komputer target tersebut mempunya SSH Server dengan support Tunnel (UDP Port) dan anda mempunyai (mengetahui) account pada komputer target tersebut.

Jurus ini tidak terpaku hanya untuk browser, namun bisa juga digunakan untuk aplikasi2 lain yang mendukung SOCKS Proxy. Karena jalur ini lah yang kita gunakan.

Selain itu, tunneling ini juga biasa digunakan untuk Anonymous Browsing, atau menjelajah internet secara anonymous. Artinya identitas asli kita akan ditutupi oleh identitas dari SSH Server yang kita tunnel. Sehingga kita pun aman.
Coba anda cek IP address anda pada saat sebelum tunneling dan pada saat tunneling.

Untuk di Windows, anda bisa menggunakan software Putty untuk melakukan tunneling ke server. Penjelasan penggunaanya, kapan-kapan saya tulis.

Lebih jauh lagi, anda bisa membuat sendiri konfigurasi untuk Tunneling pada file config ssh anda. Jika anda menggunakan Ubuntu, file tersebut ada di:
“/etc/ssh/ssh_config”

source : http://www.akemapa.com/2007/11/28/mempercepat-koneksi-dengan-ssh-tunneling/

Untuk detail penggunaan SSH, anda bisa mengunjungi situs ini:

http://souptonuts.sourceforge.net/sshtips.htm

Standard