Cisco, Networking

Fungsi ip loopback pada routing protokol ospf

Manfaat IP loopback pada router dan hubungannya routing protokol Ospf..
Jelaskan Summary Route dan Supernetting dan gunanya?

jawab

1. OSPF(open shortest path first) merupakan protokol link state yang memiliki convergence yang cepat. cara kerjanya yaitu, router mengenali seluruh tetangganya dengan paket data yang disebut LSA(link state advertisement), LSA ini berisi informasi routing yang akan disebarkan di antara router-router ospf. Untuk network yang multi akses, terdapat istilah yang disebut dengan DR (designated router) dan BDR (Backup designated router),yaitu router yang berfungsi untuk melakukan proses adjacency, di OSPF tidak semua tetangga akan menjadi adjacency (tergantung pada jenis network dan konigurasi dari router-router yang terlibat).

Nah, sekarang IP loopback, yaitu ip yang digunakan sebagai router id dalam interface-interface loopback. interface loopback sendiri adalah interface logikal, artinya interface ini secara nyata tidak ada atau virtual, oleh alasan inilah ip loopback sangat penting digunakan dalam router ospf.

Jika router ospf idak menggunakan ip loopback :
Secara default router-id dalam sebuah router diambil dari ip tertinggi, hal ini akan menjadi masalah ketika interface ini mati, maka yang akan dilakukan adalah memilih DR/BDR yang baru, akan tetapi jika kasus pada interfacenya mati-hidup dan seterusnya, maka pemilihan DR/BDR akan berulang-ulang dan tidak selesai, dan pertukaran LSA tidak akan terjadi sehingga proses convergence menjadi kacau…
ip loopback mengatasi permasalahan ini, karena ip loopback tidak akan down karena ip ini tidak menghubungkan ke suatu network tertentu atau interface nyata…
ip loopback di set dengan ip yang tertinggi yaitu dengan subnet mask 255.255.255.255…

 

2.Supernetting merupakan tenik pemgabungan dari beberapa alamat network menjadi satu alamat network dengan common Classles Inter-Domain Routing (CIDR) prefik routing. CIDR sendiri yaitu Eliminasi “class” dalam IP address yang hanya mengenal subnet. Superneting mengurangi ukuran dari routing table, secara performa konektivitas menjadi mudah, karena banyaknya network yang ada dijadikan 1. Sehingga router yang dijadikan summary route hanya memasukkan alamat network yang sudah di superneting saja, tidak semua network…

contoh :

terdapat 2 network yaitu,

172.16.2.132/30

172.16.2.120/30

karena octet pertama, kedua, dan ketiga mempunyai nilai yang sama yaitu 172.16.2

maka kita perhatikan octet ke 4, dan kita ubah ke bentuk binernya sehingga :

10000100

01111000

lakukan operasi AND sehingga menjadi 00000000

jadi, networknya 172.16.2.120/24

Advertisements
Standard
Cisco, Networking

Membuat Simulasi Jaringan VLAN

Inisialisasi

  1. Vlan 100 lab_a
  2. Vlan 200 lab_b

Perintah Switch

  • Switch>enable
  • Switch#vlan database
  • Switch(vlan)#vlan 100 name lab_a
  • Switch(vlan)#vlan 200 name lab_b
  • Switch(vlan)#exit
  • Switch#sh vlan

Setting lagi Switch nya

  • Switch#configure terminal
  • Switch(config)#interface fa 0/1
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/2
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/3
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/4
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/5
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch>enable
  • Switch#configure terminal
  • Switch(config)#interface fa 0/11
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/12
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/13
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/14
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/15
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#exit
  • Switch#sh vlan

Configurasi Router

Router>enable

  • Router#configure terminal
  • Router(config)#interface fa 0/0.100
  • Router(config-subif)#encapsulation dot1q 100
  • Router(config-subif)#ip address 172.16.10.254 255.255.0.0
  • Router(config-subif)#exit
  • Router#configure terminal
  • Router(config)#interface fa 0/0.200
  • Router(config-subif)#encapsulation dot1q 200
  • Router(config-subif)#ip address 192.168.1.254 255.255.255.0
  • Router(config-subif)#exit
  • Router(config)#interface fa 0/0
  • Router(config)#no shutdown

Configurasi Swicth [Trunk]

Switch>enable

  • Switch#configure terminal
  • Switch(config)#interface fa 0/24
  • Switch(config)#switchport mode trunk
  • Switch(config)#exit

Hasil Cek Koneksi

Standard
Server

Pentingnya Virtualisasi Server Dalam Pengolahan Data

Tingginya inflasi dan melemahnya ekonomi dunia jadi penyebab banyak perusahaan terpaksa melakukan berbagai pemangkasan, mulai dari pengurangan jumlah karyawan hingga pengurangan biaya perjalanan bisnis, sehingga tidak mengejutkan bila para pimpinan perusahaan juga dituntut menekan pengeluaran serta memaksimalkan investasi teknologi & informasi (TI) perusahaan.

 

Menurut analis dari Gartner, para vendor TI raksasa mulai mengalihkan bisnis mereka dari server besar ke server-server yang lebih kecil dengan mesin yang lebih efisien dan kompatibel satu dengan yang lain.

 

Perusahaan harus mengeluarkan biaya yang sangat besar untuk pengadaan server dengan operating system Windows yang standard saja. Belum lagi, karena kapasitas yang dibutuhkan sebenarnya hanya sekitar 20% dari kapasitas yang dimiliki oleh server-server canggih tersebut. Bagi para pemilik bisnis, ini berarti pemborosan.

 

Dengan kata lain, bayangkan jika perusahaan memiliki lima server dengan investasi ribuan dollar untuk membeli piranti lunak (software), padahal, mestinya, satu server saja sudah bisa memenuhi kebutuhan perusahaan tersebut. Berarti kapasitas empat server yang lain tidak terpakai atau tidak diperlukan.

 

Selama bertahun-tahun, Windows server merupakan software yang sangat banyak digunakan dengan berbagai aplikasi penting yang sebenarnya tidak butuh kapasitas sebesar yang dimilikinya. Unix dan Linux dapat berfungsi lebih efisien; dengan kapasitas terpakai sekitar 50% kinerja Unix dan Linux bisa jauh lebih baik dari pada Microsoft. Sayangnya, server-server ini belum banyak digunakan.

 

Virtualisasi adalah tren yang belakangan banyak dibicarakan yang juga merupakan cara tepat untuk memangkas biaya server dan TI perusahaan.

Jika sebelumnya departemen TI mengatur server berdasarkan fungsi dan kebutuhan, misalnya ada server khusus untuk email, dokumen, akunting dan bahkan server khusus untuk printing. Dengan virtualisasi, semua fungsi tersebut dapat dilakukan antar mesin sehingga jauh lebih efisien.

Karena itu, virtualisasi kini menjadi pilihan menarik bagi dunia usaha dan organisasi mulai dari yang berukuran kecil hingga besar.

Selain menghemat biaya, simak beberapa alasan penting lain, mengapa makin banyak perusahaan harus segera melakukan virtualisasi:

 

Meningkatkan kinerja server

Virtualisasi dapat menjalankan dan membuka beberapa aplikasi rumit sekaligus.

 

Hemat biaya

Virtualisai menghemat biaya karena jumlah server yang dibutuhkan jadi lebih sedikit untuk melakukan berbagai program yang dibutuhkan perusahaan.

 

Hemat energi

Tingginya biaya penggunaan energi merupakan salah satu faktor meningkatnya pengeluaran perusahaan. Virtualisasi merupakan solusi tepat untuk menghemat energi dan meredam pengeluaran perusahaan.

 

Penyelamat data

Virtualisasi dapat menyimpan data, mampu melakukan replika jaringan, dan memiliki program untuk menghindari ‘bencana’ kehilangan data.

 

Meningkatkan fleksibilitas

Virtualisasi mampu menjalankan beberapa perintah komputer dari berbagai sumber secara otomatis.

 

Cara Melakukan Virtualisasi

Untuk memulai sistem virtualisasi, sebelumnya para penyedia sistem ini harus melakukan investasi waktu dan dana serta layanan professional. Namun seiring makin banyaknya industri yang menggunakan sistem ini, sekarang sudah tersedia standar yang makin memudahkan perusahaan melakukan virtualisasi.

 

1. Membuka kunci server untuk virtualisasi

Setelah menentukan server atau software mana yang akan di-virtualisasi (atau diduplikasi), pilih komponen mana yang akan dijalankan oleh software tersebut.

Jika Anda perlu membeli peranti keras (hardware) server yang baru, bandingkan pilihan yang ditawarkan secara teliti agar sesuai dengan spesifikasi yang diperlukan.

Setiap server virtual secara fisik terlihat seperti komputer biasa yang berdiri sendiri – kenyataannya, kebanyakan server virtual menggunakan hanya satu server yang digunakan bersama.

 

2. Mudah digunakan dan digabungkan dengan yang lain

Penggunaan virtualisasi diawali dengan fungsi baru dari server lama yang dimiliki perusahaan, melakukan sambungan komponen peranti keras, lalu melakukan integrasi networking dan sistem penyimpanan. Saat hardware telah siap, pasang software virtualisasi, kemudian pindahkan aplikasi yang ada ke sistem virtual.

Dengan menggunakan software virtualisasi yang dapat secara langsung dipasang pada server, tidak dibutuhkan host operating system tersendiri, sehingga memudahkan vendor maupun perusahaan dalam melakukan integrasi atas piranti yang telah ada.

 

3. Meningkatkan kecepatan dengan biaya murah

Dengan virtualisasi, perusahaan dapat meningkatkan kerja server dan penyimpanan data, mengurangi biaya listrik termasuk untuk pendingin ruangan serta menghemat banyak tempat.

 

4. Keamanan jaringan virtualisasi

Sebagaimana komputer biasa, virtualisasi juga memiliki kekurangan, termasuk masalah keamanan. Untuk mengatasinya, setiap pengguna sebaiknya diberikan akses pribadi untuk dapat menggunakan sistem ini.

Sekarang, Anda dapat menghemat berbagai pengeluaran TI perusahaan dengan mudah.

Selamat datang di dunia virtualisasi!

Sumber:

1. InfoWorld (http://www.infoworld.com/article/08/04/07/15FE-cloud-computing-reality_1.html)

2. Citrix XenServer (http://citrix.com/English/ps2/products/product.asp?contentID=683148)

3. Microsoft enters virtualization with Windows server (http://uk.reuters.com/article/internetNews/idUKN2742106120080228)

4. The virtues of virtualization (http://www.edtechmag.com/higher/march-april-2007/the-virtues-of-virtualization.html)

Standard