Cisco, Networking

Membuat Simulasi Jaringan VLAN

Inisialisasi

  1. Vlan 100 lab_a
  2. Vlan 200 lab_b

Perintah Switch

  • Switch>enable
  • Switch#vlan database
  • Switch(vlan)#vlan 100 name lab_a
  • Switch(vlan)#vlan 200 name lab_b
  • Switch(vlan)#exit
  • Switch#sh vlan

Setting lagi Switch nya

  • Switch#configure terminal
  • Switch(config)#interface fa 0/1
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/2
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/3
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/4
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/5
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch>enable
  • Switch#configure terminal
  • Switch(config)#interface fa 0/11
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/12
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/13
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/14
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/15
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#exit
  • Switch#sh vlan

Configurasi Router

Router>enable

  • Router#configure terminal
  • Router(config)#interface fa 0/0.100
  • Router(config-subif)#encapsulation dot1q 100
  • Router(config-subif)#ip address 172.16.10.254 255.255.0.0
  • Router(config-subif)#exit
  • Router#configure terminal
  • Router(config)#interface fa 0/0.200
  • Router(config-subif)#encapsulation dot1q 200
  • Router(config-subif)#ip address 192.168.1.254 255.255.255.0
  • Router(config-subif)#exit
  • Router(config)#interface fa 0/0
  • Router(config)#no shutdown

Configurasi Swicth [Trunk]

Switch>enable

  • Switch#configure terminal
  • Switch(config)#interface fa 0/24
  • Switch(config)#switchport mode trunk
  • Switch(config)#exit

Hasil Cek Koneksi

Advertisements
Standard
Cisco, Networking

OSPF PART II | Dokumentasi.

 

 

Router A

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se 3/0
Router(config-if)#ip add 10.10.1.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#int se 2/0
Router(config-if)#ip add 10.10.2.1 255.255.255.252
Router(config-if)#clock rate 9600
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int fa 7/0
Router(config-if)#ip add 10.10.5.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip add 192.168.1.10 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#router ospf 90
Router(config-router)#network 10.10.1.0 255.255.255.252 area 9
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
Router(config-router)#network 10.10.5.0 255.255.255.252 area 9
Router(config-router)#network 192.168.1.0 255.255.255.0 area 9
Router(config-router)#log-adjancency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write

Router B

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se 2/0
Router(config-if)#ip add 10.10.2.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int se 3/0
Router(config-if)#ip add 10.10.3.1 255.255.255.252
Router(config-if)#clock rate 9600
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#int fa7/0
Router(config-if)#ip add 10.10.6.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.10 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#%IP-4-DUPADDR: Duplicate address 192.168.3.10 on FastEthernet0/0, sourced by 0006.2A08.30B1

Router(config-if)#exit
Router(config)#router ospf 90
Router(config-router)#network 10.10.2.0 255.255.255.252
% Incomplete command.
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
00:35:55: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.1.10 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.3.0 255.255.255.252 area 9
Router(config-router)#network 10.10.6.0 255.255.255.252 area 9
Router(config-router)#network 192.168.3.0 255.255.255.0 area 9
Router(config-router)#log adjacency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration…
[OK]

Router C

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se 2/0
Router(config-if)#ip add 10.10.2.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int se 3/0
Router(config-if)#ip add 10.10.3.1 255.255.255.252
Router(config-if)#clock rate 9600
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#int fa7/0
Router(config-if)#ip add 10.10.6.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.10 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#%IP-4-DUPADDR: Duplicate address 192.168.3.10 on FastEthernet0/0, sourced by 0006.2A08.30B1

Router(config-if)#exit
Router(config)#router ospf 90
Router(config-router)#network 10.10.2.0 255.255.255.252
% Incomplete command.
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
00:35:55: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.1.10 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.3.0 255.255.255.252 area 9
Router(config-router)#network 10.10.6.0 255.255.255.252 area 9
Router(config-router)#network 192.168.3.0 255.255.255.0 area 9
Router(config-router)#log adjacency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration…
[OK]

Router D

Router(config)#int se 3/0
Router(config-if)#ip add 10.10.4.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#int fa 7/0
Router(config-if)#ip add 10.10.5.2
% Incomplete command.
Router(config-if)#ip add 10.10.5.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

 

 

 

 

Router con0 is now available

 

 
Press RETURN to get started.

 

 

 

 

 

 

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.4.10 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#

 

 

 
Router con0 is now available

 

 
Press RETURN to get started.

 

 

 

 

 

 

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 90
Router(config-router)#network 10.10.3.2 255.255.255.252 are 9
Router(config-router)#network 10.10.3.2 255.255.255.252 are 9
00:58:04: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.3.10 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.3.0 255.255.255.252 are 9
Router(config-router)#network 10.10.4.0 255.255.255.252 are 9
Router(config-router)#network 10.10.4.0 255.255.255.252 are 9
00:59:10: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.2.10 on Serial3/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.4.0 255.255.255.252 area 9
Router(config-router)#network 10.10.3.0 255.255.255.252 area 9
Router(config-router)#network 192.168.4.0 255.255.255.0 area 9
Router(config-router)#log-adjecency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration…
[OK]
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 90
Router(config-router)#network 10.10.5.0 255.255.255.252 area 9
Router(config-router)#log-adjancency
01:04:32: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.1.10 on FastEthernet7/0 from LOADING to FULL, Loading Do
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjancency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration…
[OK]

Standard
Ppentest, Win Security

Pentest

PenTest secara umum merupakan singkatan dari Penetration Test… Artinya (menurut Wikipedia dengan sedikit perubahan) adalah suatu metode untuk mengevaluasi keamanan sistem komputer atau jaringan dengan mensimulasikan serangan yang mungkin terjadi dari pihak yang tidak bertanggung jawab (misalnya Black Hat Hacker ataupun kracker)…

Jadi, secara garis besar, kegiatan PenTest merupakan kegiatan yang memiliki etika yang baik, dengan keadaan yang terbuka dan dilakukan oleh para White Hat Hacker untuk mencoba masuk ke dalam sistem dengan menggunakan berbagai teknik yang mungkin dapat dilakukan / dicoba oleh para Black Hat Hacker maupun kracker… sifatnya lebih ke defensive purpose (mencoba menyerang, kemudian memberitahukan letak celah untuk diperbaiki oleh pemilik sistem yang bersangkutan)…

Di dalam PenTest, pasti akan terdengar lagi istilah PenTester… Dari namanya, pasti sudah dapat ketebak yach ini apa… yach, PenTester ini merupakan pemainnya, pemain dari kegiatan PenTest…PenTester ini biasanya White Hat Hacker… Orang-Orang yang bekerja pada suatu instansi tertentu yang berada di bawah surat perjanjian untuk tidak membocorkan informasi apapun yang ada pada kegiatan PenTest… namun, tidak menutup kemungkinan bahwa pelaku kegiatan PenTest ini bisa juga dari kalangan Black Hat ataupun Grey Hat… terkadang, ada alasan tersendiri dari suatu instansi untuk memakai tenang yang seperti ini (semua kembali kepada kebijakan masing-masing)…

Nah, menurut salah satu penyelenggara sertifikasi yang berhubungan dengan Hacking (EC – Cou***l), pada umumnya, kegiatan Hacking dilakukan melalui life cycle seperti ini:

1. Reconnaissance
–> lebih ke arah Information Gathering… Terbagi menjadi 2, ada aktif, ada pula pasif…
–> Untuk Pasif : pencarian dilakukan dengan tidak berhubungan langsung dengan target, seperti melalui InterNet…
–> Untuk Aktif : pencarian dilakukan langsung dengan berhubungan dengan target… Biasanya dikenal dengan sebutan Social Engineering… Ingat Kevin Mitnick…

2. Scanning
–> lebih ke arah vulnerability scanning… pencarian kelemahan dari sistem yang sedang dites…

3. Gaining Access
–> lebih ke arah mencoba untuk mengambil alih sistem yang sedang dites…

4. Maintaining Access
–> lebih ke arah meninggalkan jejak tersembunyi, sebagai contoh, meletakan backdoor… pastinya, seorang Attacker tidak ingin bersusah payah lagi mengambil alih sistem yang telah berhasil diterobos… Bisa saja keesokan harinya, sang administrator telah menge-patch sistemnya, sehingga Attacker tidak dapat lagi masuk lewat celah yang sama…

5. Clearing Tracks
–> Seorang Attacker pastinya tidak ingin aktivitas Hacking mereka berujung di penjara, jadi, mereka pasti menghapus jejak mereka setelah meletakan pintu masuk lewat belakang dan setelah mereka utak-atik sistem yang berhasil diterobos…

Nah, ini merupakan gambaran Hacking yang biasa dilakukan seorang Attacker… namun, untuk kegiatan PenTest resmi, biasanya hanya sampai Gaining Access… setelah berhasil mencapai tahap 3, maka pekerjaan mereka telah dinyatakan selesai untuk setiap celah yang ditemukan…

Standard