Cisco, Networking

Fungsi ip loopback pada routing protokol ospf

Manfaat IP loopback pada router dan hubungannya routing protokol Ospf..
Jelaskan Summary Route dan Supernetting dan gunanya?

jawab

1. OSPF(open shortest path first) merupakan protokol link state yang memiliki convergence yang cepat. cara kerjanya yaitu, router mengenali seluruh tetangganya dengan paket data yang disebut LSA(link state advertisement), LSA ini berisi informasi routing yang akan disebarkan di antara router-router ospf. Untuk network yang multi akses, terdapat istilah yang disebut dengan DR (designated router) dan BDR (Backup designated router),yaitu router yang berfungsi untuk melakukan proses adjacency, di OSPF tidak semua tetangga akan menjadi adjacency (tergantung pada jenis network dan konigurasi dari router-router yang terlibat).

Nah, sekarang IP loopback, yaitu ip yang digunakan sebagai router id dalam interface-interface loopback. interface loopback sendiri adalah interface logikal, artinya interface ini secara nyata tidak ada atau virtual, oleh alasan inilah ip loopback sangat penting digunakan dalam router ospf.

Jika router ospf idak menggunakan ip loopback :
Secara default router-id dalam sebuah router diambil dari ip tertinggi, hal ini akan menjadi masalah ketika interface ini mati, maka yang akan dilakukan adalah memilih DR/BDR yang baru, akan tetapi jika kasus pada interfacenya mati-hidup dan seterusnya, maka pemilihan DR/BDR akan berulang-ulang dan tidak selesai, dan pertukaran LSA tidak akan terjadi sehingga proses convergence menjadi kacau…
ip loopback mengatasi permasalahan ini, karena ip loopback tidak akan down karena ip ini tidak menghubungkan ke suatu network tertentu atau interface nyata…
ip loopback di set dengan ip yang tertinggi yaitu dengan subnet mask 255.255.255.255…

 

2.Supernetting merupakan tenik pemgabungan dari beberapa alamat network menjadi satu alamat network dengan common Classles Inter-Domain Routing (CIDR) prefik routing. CIDR sendiri yaitu Eliminasi “class” dalam IP address yang hanya mengenal subnet. Superneting mengurangi ukuran dari routing table, secara performa konektivitas menjadi mudah, karena banyaknya network yang ada dijadikan 1. Sehingga router yang dijadikan summary route hanya memasukkan alamat network yang sudah di superneting saja, tidak semua network…

contoh :

terdapat 2 network yaitu,

172.16.2.132/30

172.16.2.120/30

karena octet pertama, kedua, dan ketiga mempunyai nilai yang sama yaitu 172.16.2

maka kita perhatikan octet ke 4, dan kita ubah ke bentuk binernya sehingga :

10000100

01111000

lakukan operasi AND sehingga menjadi 00000000

jadi, networknya 172.16.2.120/24

Advertisements
Standard
Cisco, Networking

Redistribute Routing Protocol ( Static, RIP, OSPF dan EIGRP )

Topologi

Skenario :

Router Interface Address Network Broadcast
ISP fastEthernet 0/1 111.111.111.1/30 111.111.111.0/30 111.111.111.3/30
  fastEthernet 0/0 111.111.111.5/30 111.111.111.4/30 111.111.111.7/30
HQ fastEthernet 0/0 10.0.0.1/30 10.0.0.0/30 10.0.0.3/30
  fastEthernet 0/1 10.0.0.13/30 10.0.0.12/30 10.0.0.15/30
  fastEthernet 1/0 10.0.0.45/30 10.0.0.44/30 10.0.0.47/30
  fastEthernet 1/1 10.0.0.33/30 10.0.0.32/30 10.0.0.35/30
  ethernet 0/0/0 111.111.111.6/30 111.111.111.4/30 111.111.111.7/30
  ethernet 0/2/0 10.0.0.25/29 10.0.0.24/30 10.0.0.31/30
loopback 0 10.0.0.60/32
Static_1 fastEthernet 0/1 10.0.0.2/30 10.0.0.0/30 10.0.0.3/30
fastEthernet 0/0 10.0.0.5/30 10.0.0.4/30 10.0.0.7/30
Static_2 fastEthernet 0/1 10.0.0.6/30 10.0.0.4/30 10.0.0.7/30
fastEthernet 0/0 10.0.0.9/30 10.0.0.8/30 10.0.0.11/30
Static_3 fastEthernet 0/0 10.0.0.10/30 10.0.0.8/30 10.0.0.11/30
fastEthernet 0/1 10.0.1.129/27 10.0.1.128/27 10.0.1.163/27
Rip_1 fastEthernet 0/0 10.0.0.14/30 10.0.0.12/30 10.0.0.15/30
fastEthernet 0/1 10.0.0.17/30 10.0.0.16/30 10.0.0.19/30
Rip_2 fastEthernet 0/0 10.0.0.18/30 10.0.0.16/30 10.0.0.19/30
fastEthernet 0/1 10.0.0.21/30 10.0.0.20/30 10.0.0.23/30
Rip_3 fastEthernet 0/0 10.0.0.22/30 10.0.0.20/30 10.0.0.23/30
fastEthernet 0/1 10.0.1.1/25 10.0.1.0/25 10.0.1.127/25
Ospf_1 fastEthernet 0/0 10.0.0.34/30 10.0.0.32/30 10.0.0.35/30
  fastEthernet 0/1 10.0.0.37/30 10.0.0.36/30 10.0.0.39/30
loopback 0 10.0.0.57/32
Ospf_2 fastEthernet 0/0 10.0.0.38/32 10.0.0.36/30 10.0.0.39/30
  fastEthernet 0/1 10.0.0.41/32 10.0.0.40/30 10.0.0.43/30
loopback 0 10.0.0.58/32
Ospf_3 fastEthernet 0/0 10.0.0.42/30 10.0.0.40/30 10.0.0.43/30
  fastEthernet 0/1 10.0.0.129/25 10.0.0.128/30 10.0.0.163/30
loopback 0 10.0.0.59/32
Eigrp_1 fastEthernet 0/0 10.0.0.46/30 10.0.0.44/30 10.0.0.47/30
fastEthernet 0/1 10.0.0.49/30 10.0.0.48/30 10.0.0.51/30
Eigrp_2 fastEthernet 0/0 10.0.0.50/30 10.0.0.48/30 10.0.0.51/30
fastEthernet 0/1 10.0.0.53/30 10.0.0.52/30 10.0.0.55/30
Eigrp_3 fastEthernet 0/0 10.0.0.54/30 10.0.0.452/30 10.0.0.55/30
  fastEthernet 0/1 10.0.0.65/26 10.0.0.64/26 10.0.0.127/26

Configuration :

Router Static_1

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname Static_1

Static_1(config)#interface fastEthernet 0/1

Static_1(config-if)#no shutdown

Static_1(config-if)#ip address 10.0.0.2 255.255.255.252

Static_1(config-if)#exit

Static_1(config)#interface fastEthernet 0/0

Static_1(config-if)#no shutdown

Static_1(config-if)#ip address 10.0.0.5 255.255.255.252

Static_1(config-if)#exit

Static_1(config)#ip route 10.0.0.8 255.255.255.252 10.0.0.6

Static_1(config)#ip route 10.0.1.128 255.255.255.224 10.0.0.10

Static_1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1

Static_1(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Static_1#^Z

Static_1#wr mem

Building configuration…

[OK]

Static_1#

Router Static_2

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname Static_2

Static_2(config)#interface fastEthernet 0/0

Static_2(config-if)#no shutdown

Static_2(config-if)#ip address 10.0.0.9 255.255.255.252

Static_2(config-if)#exit

Static_2(config)#interface fastEthernet 0/1

Static_2(config-if)#ip address 10.0.0.6 255.255.255.252

Static_2(config-if)#exit

Static_2(config)#ip route 10.0.0.0 255.255.255.252 10.0.0.

Static_2(config)#ip route 10.0.1.128 255.255.255.224 10.0.0.10

Static_2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.5

Static_2(config)#exit

Static_2#

%SYS-5-CONFIG_I: Configured from console by console

Static_2#wr mem

Building configuration…

[OK]

Static_2#

Router Static_3

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname Static_3

Static_3(config)#interface fastEthernet 0/0

Static_3(config-if)#no shutdown

Static_3(config-if)#ip address 10.0.0.10 255.255.255.252

Static_3(config-if)#exit

Static_3(config)#interface fastEthernet 0/1

Static_3(config-if)#no shutdown

Static_3(config-if)#ip address 10.0.1.129 255.255.255.224

Static_3(config-if)#exit

Static_3(config)#ip dhcp po

Static_3(config)#ip dhcp pool Static_3

Static_3(dhcp-config)#default-router 10.0.1.129

Static_3(dhcp-config)#network 10.0.1.128 255.255.255.224

Static_3(dhcp-config)#dns-server 10.0.0.30

Static_3(dhcp-config)#exit

Static_3(config)#ip route 10.0.0.0 255.255.255.252 10.0.0.5

Static_3(config)#ip route 10.0.0.4 255.255.255.252 10.0.0.9

Static_3(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.9

Static_3(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

Static_3#wr mem

Building configuration…

[OK]

Static_3#

Router RIP_1

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RIP_1

RIP_1(config)#interface fastEthernet 0/0

RIP_1(config-if)#no shutdown

RIP_1(config-if)#ip address 10.0.0.14 255.255.255.252

RIP_1(config-if)#exit

RIP_1(config)#interface fastEthernet 0/1

RIP_1(config-if)#no shutdown

RIP_1(config-if)#ip address 10.0.0.17 255.255.255.252

RIP_1(config-if)#exit

RIP_1(config)#router rip

RIP_1(config-router)#version 2

RIP_1(config-router)#network 10.0.0.12

RIP_1(config-router)#network 10.0.0.16

RIP_1(config-router)#exit

RIP_1(config-router)#ip route 0.0.0.0 0.0.0.0 10.0.0.13

RIP_1(config)#exit

RIP_1#

%SYS-5-CONFIG_I: Configured from console by console

RIP_1#wr mem

Building configuration…

[OK]

RIP_1#

Router RIP_2

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RIP_2

RIP_2(config)#interface fas

RIP_2(config)#interface fastEthernet 0/0

RIP_2(config-if)#no shutdown

RIP_2(config-if)#ip address 10.0.0.18 255.255.255.252

RIP_2(config-if)#exit

RIP_2(config)#interface fastEthernet 0/1

RIP_2(config-if)#no shutdown

RIP_2(config-if)#ip address 10.0.0.21 255.255.255.252

RIP_2(config-if)#exit

RIP_2(config)#router rip

RIP_2(config-router)#version 2

RIP_2(config-router)#network 10.0.0.16

RIP_2(config-router)#network 10.0.0.20

RIP_2(config-router)#exit

RIP_2(config-router)# ip route 0.0.0.0 0.0.0.0 10.0.0.17

RIP_2(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

RIP_2#

RIP_2#wr mem

Building configuration…

[OK]

RIP_2#

Router RIP_3

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname RIP_3

RIP_3(config)#interface fastEthernet 0/0

RIP_3(config-if)#no shutdown

RIP_3(config-if)#ip address 10.0.0.22 255.255.255.252

RIP_3(config-if)#exit

RIP_3(config)#interface fastEthernet 0/1

RIP_3(config-if)#no shutdown

RIP_3(config-if)#ip address 10.0.1.1 255.255.255.128

RIP_3(config-if)#exit

RIP_3(config)#ip dhcp pool RIP_3

RIP_3(dhcp-config)#default-router 10.0.1.1

RIP_3(dhcp-config)#network 10.0.1.0 255.255.255.128

RIP_3(dhcp-config)#dns-server 10.0.0.30

RIP_3(dhcp-config)#exit

RIP_3(config)#router rip

RIP_3(config-router)#version 2

RIP_3(config-router)#network 10.0.0.20

RIP_3(config-router)#network 10.0.1.0

RIP_3(config-router)#exit

RIP_3(config-if)# ip route 0.0.0.0 0.0.0.0 10.0.0.21

RIP_3(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

RIP_3#

RIP_3#wr mem

Building configuration…

[OK]

RIP_3#

 

 

 

Router OSPF_1

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname OSPF_1

OSPF_1(config)#interface fastEthernet 0/0

OSPF_1(config-if)#no shutdown

OSPF_1(config-if)#ip address 10.0.0.34 255.255.255.252

OSPF_1(config-if)#exit

OSPF_1(config)#interface fastEthernet 0/1

OSPF_1(config-if)#ip address 10.0.0.37 255.255.255.252

OSPF_1(config-if)#no shutdown

OSPF_1(config-if)#exit

OSPF_1(config)#interface loopback 0

OSPF_1(config-if)#ip address 10.0.0.57 255.255.255.255

OSPF_1(config-if)#exit

OSPF_1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.33

OSPF_1(config)#router ospf 1

OSPF_1(config-router)#network 10.0.0.32 0.0.0.3 area 0

OSPF_1(config-router)#network 10.0.0.36 0.0.0.3 area 0

OSPF_1(config-router)#log-adjacency-changes

OSPF_1(config-router)#router-id 10.0.0.56

OSPF_1(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

OSPF_1(config-router)#exit

OSPF_1(config)#^Z

OSPF_1#

%SYS-5-CONFIG_I: Configured from console by console

OSPF_1#wr mem

Building configuration…

[OK]

OSPF_1#

Router OSPF_2

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hos

Router(config)#hostname OSPF_2

OSPF_2(config)#interface fastEthernet 0/0

OSPF_2(config-if)#no shutdown

OSPF_2(config-if)#ip address 10.0.0.38 255.255.255.252

OSPF_2(config-if)#exit

OSPF_2(config)#interface fastEthernet 0/1

OSPF_2(config-if)#no shutdown

OSPF_2(config-if)#ip address 10.0.0.41 255.255.255.252

OSPF_2(config-if)#exit

OSPF_2(config)#interface loopback 0

OSPF_2(config-if)#ip address 10.0.0.58 255.255.255.255

OSPF_2(config-if)#exit

OSPF_2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.37

OSPF_2(config)#router ospf 1

OSPF_2(config-router)#network 10.0.0.36 0.0.0.3 area 0

OSPF_2(config-router)#network 10.0.0.40 0.0.0.3 area 0

OSPF_2(config-router)#log-adjacency-changes

OSPF_2(config-router)#router-id 10.0.0.57

OSPF_2(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

OSPF_2(config-router)#exit

OSPF_2(config)#^Z

OSPF_2#

%SYS-5-CONFIG_I: Configured from console by console

OSPF_2#wr mem

Building configuration…

[OK]

OSPF_2#

Router OSPF_3

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname OSPF_3

OSPF_3(config)#interface fastEthernet 0/0

OSPF_3(config-if)#no shutdown

OSPF_3(config-if)#ip address 10.0.0.42 255.255.255.252

OSPF_3(config-if)#exit

OSPF_3(config)#interface loopback 0

OSPF_3(config-if)#ip address 10.0.0.59 255.255.255.255

OSPF_3(config-if)#exit

OSPF_3(config)#interface fastEthernet 0/1

OSPF_3(config-if)#no shutdown

OSPF_3(config-if)#ip address 10.0.0.129 255.255.255.128

OSPF_3(config-if)#exit

OSPF_3(config)#ip dhcp pool ospf_3

OSPF_3(dhcp-config)#default-router 10.0.0.129

OSPF_3(dhcp-config)#network 10.0.0.128 255.255.255.128

OSPF_3(dhcp-config)#dns-server 10.0.0.30

OSPF_3(dhcp-config)#exit

OSPF_3(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.41

OSPF_3(config)#router ospf 1.

OSPF_3(config-router)#network 10.0.0.40 0.0.0.3 area 0

OSPF_3(config-router)#network 10.0.0.129 0.0.0.127 area 0

OSPF_3(config-router)#router-id 10.0.0.58

OSPF_3(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

OSPF_3(config-router)#exit

OSPF_3(config)#exit

OSPF_3#

%SYS-5-CONFIG_I: Configured from console by console

OSPF_3#wr mem

Building configuration…

[OK]

OSPF_3#

EIGRP_1

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname EIGRP_1

EIGRP_1(config)#interface fastEthernet 0/0

EIGRP_1(config-if)#no shutdown

EIGRP_1(config-if)#ip address 10.0.0.46 255.255.255.252

EIGRP_1(config-if)#exit

EIGRP_1(config)#interface fastEthernet 0/1

EIGRP_1(config-if)#no shutdown

EIGRP_1(config-if)#ip address 10.0.0.49 255.255.255.252

EIGRP_1(config-if)#exit

EIGRP_1(config-if)#ip route 0.0.0.0 0.0.0.0 10.0.0.45

EIGRP_1(config)#router eigrp 1

EIGRP_1(config-router)#network 10.0.0.44 0.0.0.3

EIGRP_1(config-router)#network 10.0.0.48 0.0.0.3

EIGRP_1(config-router)#exit

EIGRP_1(config)#exit

EIGRP_1#

%SYS-5-CONFIG_I: Configured from console by console

EIGRP_1#wr mem

Building configuration…

[OK]

EIGRP_1#

EIGRP_2

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname EIGRP_2

EIGRP_2(config)#interface fastEthernet 0/0

EIGRP_2(config-if)#no shutdown

EIGRP_2(config-if)#ip address 10.0.0.50 255.255.255.252

EIGRP_2(config-if)#exit

EIGRP_2(config)#interface fastEthernet 0/1

EIGRP_2(config-if)#no shutdown

EIGRP_2(config-if)#ip address 10.0.0.53 255.255.255.252

EIGRP_2(config-if)#exit

EIGRP_1(config-if)#ip route 0.0.0.0 0.0.0.0 10.0.0.49

EIGRP_2(config)#router eigrp 1

EIGRP_2(config-router)#network 10.0.0.48 0.0.0.3

EIGRP_2(config-router)#network 10.0.0.52 0.0.0.3

EIGRP_2(config-router)#exit

EIGRP_2(config)#exit

EIGRP_2#

%SYS-5-CONFIG_I: Configured from console by console

EIGRP_2#w mem

Building configuration…

[OK]

EIGRP_2#

EIGRP_3

Router>

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hos

Router(config)#hostname EIGRP_3

EIGRP_3(config)#interface fastEthernet 0/0

EIGRP_3(config-if)#no shutdown

EIGRP_3(config-if)#ip address 10.0.0.54 255.255.255.252

EIGRP_3(config-if)#exit

EIGRP_3(config)#interface fastEthernet 0/1

EIGRP_3(config-if)#no shutdown

EIGRP_3(config-if)#ip address 10.0.0.65 255.255.255.192

EIGRP_3(config-if)#exit

EIGRP_3(config-if)# ip route 0.0.0.0 0.0.0.0 10.0.0.53

EIGRP_3(config)#ip dhcp pool eigrp_3

EIGRP_3(dhcp-config)#default-router 10.0.0.65

EIGRP_3(dhcp-config)#network 10.0.0.64 255.255.255.192

EIGRP_3(dhcp-config)#dns-server 10.0.0.30

EIGRP_3(dhcp-config)#exit

EIGRP_3(config)#router eigrp 1

EIGRP_3(config-router)#network 10.0.0.52 0.0.0.3

EIGRP_3(config-router)#network 10.0.0.64 0.0.0.63

EIGRP_3(config-router)#exit

EIGRP_3(config)#^Z

EIGRP_3#

%SYS-5-CONFIG_I: Configured from console by console

EIGRP_3#wr mem

Building configuration…

[OK]

EIGRP_3#

Router HQ

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname HQ

HQ(config)#interface fastEthernet 0/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.1 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface fastEthernet 0/1

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.13 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface ethernet 0/2/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.25 255.255.255.248

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface fastEthernet 1/1

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.33 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface fastEthernet 1/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 10.0.0.45 255.255.255.252

HQ(config-if)#ip nat inside

HQ(config-if)#exit

HQ(config)#interface ethernet 0/0/0

HQ(config-if)#no shutdown

HQ(config-if)#ip address 111.111.111.6 255.255.255.252

HQ(config-if)#ip nat outside

HQ(config-if)#exit

HQ(config)#interface loopback 0

HQ(config-if)#ip address 10.0.0.60 255.255.255.255

HQ(config-if)#exit

HQ(config)#ip route 10.0.0.4 255.255.255.252 10.0.0.2

HQ(config)#ip route 10.0.0.8 255.255.255.252 10.0.0.6

HQ(config)#ip route 10.0.1.128 255.255.255.224 10.0.0.10

HQ(config)#ip route 0.0.0.0 0.0.0.0 111.111.111.5

HQ(config)#ip nat inside source list 1 interface ethernet 0/0/0 overload

HQ(config)#access-list 1 permit any

HQ(config)#ip nat inside source static 10.0.0.29 111.111.111.6

HQ(config)#router rip

HQ(config-router)#version 2

HQ(config-router)#network 10.0.0.12

HQ(config-router)#redistribute eigrp 1 metric 1

HQ(config-router)#redistribute ospf 1 metric 1

HQ(config-router)#redistribute static metric 1

HQ(config-router)#exit

HQ(config)#router ospf 1

HQ(config-router)#network 10.0.0.32 0.0.0.3 area 0

HQ(config-router)#log-adjacency-changes

HQ(config-router)#router-id 10.0.0.59

HQ(config-router)#Reload or use “clear ip ospf process” command, for this to take effect

HQ(config-router)# redistribute rip subnets

HQ(config-router)# redistribute eigrp 1 subnets

HQ(config-router)# redistribute static metric 1 subnets

HQ(config-router)#exit

HQ(config)#router eigrp 1

HQ(config-router)#network 10.0.0.44 0.0.0.3

HQ(config-router)#network 10.0.0.24 0.0.0.7

HQ(config-router)#redistribute rip metric 1 1 1 1 1

HQ(config-router)#redistribute ospf 1 metric 1 1 1 1 1

HQ(config-router)# redistribute static

HQ(config-router)#exit

HQ(config)#ex

HQ#

%SYS-5-CONFIG_I: Configured from console by console

HQ#wr mem

Building configuration…

[OK]

HQ#

Router_ISP

Router>ena

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname ISP

ISP(config)#interface fastEthernet 0/0

ISP(config-if)#no shutdown

ISP(config-if)#ip address 111.111.111.5 255.255.255.252

ISP(config-if)#exit

ISP(config)#interface fastEthernet 0/1

ISP(config-if)#no shutdown

ISP(config-if)#ip address 111.111.111.1 255.255.255.252

ISP(config-if)#exit

ISP(config)# ip route 0.0.0.0 0.0.0.0 111.111.111.6

ISP(config)#^Z

ISP#

%SYS-5-CONFIG_I: Configured from console by console

ISP#wr mem

Building configuration…

[OK]

Standard
Cisco, Networking

OSPF PART II | Dokumentasi.

 

 

Router A

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se 3/0
Router(config-if)#ip add 10.10.1.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#int se 2/0
Router(config-if)#ip add 10.10.2.1 255.255.255.252
Router(config-if)#clock rate 9600
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int fa 7/0
Router(config-if)#ip add 10.10.5.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip add 192.168.1.10 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#router ospf 90
Router(config-router)#network 10.10.1.0 255.255.255.252 area 9
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
Router(config-router)#network 10.10.5.0 255.255.255.252 area 9
Router(config-router)#network 192.168.1.0 255.255.255.0 area 9
Router(config-router)#log-adjancency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write

Router B

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se 2/0
Router(config-if)#ip add 10.10.2.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int se 3/0
Router(config-if)#ip add 10.10.3.1 255.255.255.252
Router(config-if)#clock rate 9600
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#int fa7/0
Router(config-if)#ip add 10.10.6.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.10 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#%IP-4-DUPADDR: Duplicate address 192.168.3.10 on FastEthernet0/0, sourced by 0006.2A08.30B1

Router(config-if)#exit
Router(config)#router ospf 90
Router(config-router)#network 10.10.2.0 255.255.255.252
% Incomplete command.
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
00:35:55: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.1.10 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.3.0 255.255.255.252 area 9
Router(config-router)#network 10.10.6.0 255.255.255.252 area 9
Router(config-router)#network 192.168.3.0 255.255.255.0 area 9
Router(config-router)#log adjacency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration…
[OK]

Router C

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int se 2/0
Router(config-if)#ip add 10.10.2.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit
Router(config)#int se 3/0
Router(config-if)#ip add 10.10.3.1 255.255.255.252
Router(config-if)#clock rate 9600
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

Router(config-if)#exit
Router(config)#int fa7/0
Router(config-if)#ip add 10.10.6.1 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.3.10 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#%IP-4-DUPADDR: Duplicate address 192.168.3.10 on FastEthernet0/0, sourced by 0006.2A08.30B1

Router(config-if)#exit
Router(config)#router ospf 90
Router(config-router)#network 10.10.2.0 255.255.255.252
% Incomplete command.
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
Router(config-router)#network 10.10.2.0 255.255.255.252 area 9
00:35:55: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.1.10 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.3.0 255.255.255.252 area 9
Router(config-router)#network 10.10.6.0 255.255.255.252 area 9
Router(config-router)#network 192.168.3.0 255.255.255.0 area 9
Router(config-router)#log adjacency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration…
[OK]

Router D

Router(config)#int se 3/0
Router(config-if)#ip add 10.10.4.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#int fa 7/0
Router(config-if)#ip add 10.10.5.2
% Incomplete command.
Router(config-if)#ip add 10.10.5.2 255.255.255.252
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

 

 

 

 

Router con0 is now available

 

 
Press RETURN to get started.

 

 

 

 

 

 

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.4.10 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#

 

 

 
Router con0 is now available

 

 
Press RETURN to get started.

 

 

 

 

 

 

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 90
Router(config-router)#network 10.10.3.2 255.255.255.252 are 9
Router(config-router)#network 10.10.3.2 255.255.255.252 are 9
00:58:04: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.3.10 on Serial2/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.3.0 255.255.255.252 are 9
Router(config-router)#network 10.10.4.0 255.255.255.252 are 9
Router(config-router)#network 10.10.4.0 255.255.255.252 are 9
00:59:10: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.2.10 on Serial3/0 from LOADING to FULL, Loading Done

Router(config-router)#network 10.10.4.0 255.255.255.252 area 9
Router(config-router)#network 10.10.3.0 255.255.255.252 area 9
Router(config-router)#network 192.168.4.0 255.255.255.0 area 9
Router(config-router)#log-adjecency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end

%SYS-5-CONFIG_I: Configured from console by console
Router#write
Building configuration…
[OK]
Router#
Router#
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 90
Router(config-router)#network 10.10.5.0 255.255.255.252 area 9
Router(config-router)#log-adjancency
01:04:32: %OSPF-5-ADJCHG: Process 90, Nbr 192.168.1.10 on FastEthernet7/0 from LOADING to FULL, Loading Do
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjancency-changes
^
% Invalid input detected at ‘^’ marker.

Router(config-router)#log-adjacency-changes
Router(config-router)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#write
Building configuration…
[OK]

Standard