Cisco, Linux, Networking, Server

Kolaborasi RIP Cisco dan Mikrotik

gns

Bahan-bahan nya:

  • GNS3. (ready hypervisor)
  • Virtual Box.

Adapter yg di pake di Vbox.

XP: internal (name intA)

Centos: Internal (name intaB

Mikrotik: Host only adapters, Internal (intA dan intB) dan NAT.

internal A dan B network nya beda. dan meraka masing ternoneksi ke internal nya mikrotik. Host Only adapter nya konek ke Cisco, Cico punya 2 interface yang 1 nya nyambung ke mikrotik lwt vbox adapter, satunya lagi ke xp nyambung ke vbox adapter.

nb: Switch itu pajangan doang!

Configurasi.

  • Set IP cisco dan mikrotik. (search aja)
  • Set RIP cisco dan Mikrotik.
  • Set NAT. biar mikrotik bisa inetan.

Sumber koneksi inetan dari USB tehthering Android 🙂

Konfigurasi RIP di Mikrotik.

Gampang men! (sampe sini udah harus set semua ip, mulai dr cisco smpe mikrotik dan juga client)

  1. Masuk pake winbox.
  2. Menu Routing — Tab Network. (set rip, sama kayak set RIP cisco, gak jauh beda)

rip#this is my note aka my little brain, may be only me can understand

note:  Total Network ada 4, Total ip ada 8. Colusion di windows karna tethering  😡

Advertisements
Standard
Cisco, Networking

PAT (Port Address Translation)

PATSet ROUTER ISP

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host ISP
ISP(config)#no ip do
ISP(config)#no ip dom
ISP(config)#no ip domain-lookup
ISP(config)#int fa0/0
ISP(config-if)#ip add 198.133.219.2 255.255.255.252
ISP(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
ISP(config-if)#int lo0

ISP(config-if)#
%LINK-5-CHANGED: Interface Loopback0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

ISP(config-if)#ip add 192.31.7.1 255.255.255.0
ISP(config-if)#ex
ISP(config)#ex
ISP#
%SYS-5-CONFIG_I: Configured from console by console

ISP#copy
ISP#copy r
ISP#copy running-config s
ISP#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
ISP#
ISP#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Set ROUTER Company

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host Company
Company(config)#int fa0/0
Company(config-if)#ip add 172.16.10.1 255.255.255.0
Company(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Company(config-if)#int fa0/1
Company(config-if)#ip add 198.133.219.1 255.255.255.252
Company(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Company(config-if)#exit
Company(config)#ip r
Company(config)#ip route 0.0.0.0 0.0.0.0 198.133.219.2
Company(config)#ac
Company(config)#access-list 1 pe
Company(config)#access-list 1 permit 172.16.10.0 0.0.0.255
Company(config)#ip nat inside so
Company(config)#ip nat inside source list 1 int fa0/1
Company(config)#ip nat inside source list 1 int fa0/1 overload
Company(config)#int fa0/0
Company(config-if)#ip nat inside
Company(config-if)#int fa0/1
Company(config-if)#ip nat outside
Company(config-if)#^Z
Company#
%SYS-5-CONFIG_I: Configured from console by console

Company#cop
Company#copy r
Company#copy running-config s
Company#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
Company#

Standard
Cisco, Networking

RIP V1

rip1

Set RIPv1.

Router 0

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ex
Router(config)#ro
Router(config)#router ri
Router(config)#router rip
Router(config-router)#ne
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.1.0
Router(config-router)#
Router#

Router 1

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#ex
Router(config)#int fa0/1
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#ex
Router(config)#rou
Router(config)#router r
Router(config)#router rip
Router(config-router)#ne
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#

Router2

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 192.168.2.2 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ex
Router(config)#rou
Router(config)#router r
Router(config)#router rip
Router(config-router)#ne
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#

 

Standard