Cisco, Networking

Membuat Simulasi Jaringan VLAN

Inisialisasi

  1. Vlan 100 lab_a
  2. Vlan 200 lab_b

Perintah Switch

  • Switch>enable
  • Switch#vlan database
  • Switch(vlan)#vlan 100 name lab_a
  • Switch(vlan)#vlan 200 name lab_b
  • Switch(vlan)#exit
  • Switch#sh vlan

Setting lagi Switch nya

  • Switch#configure terminal
  • Switch(config)#interface fa 0/1
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/2
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/3
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/4
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/5
  • Switch(config-if)#switchport access vlan 100
  • Switch(config-if)#exit
  • Switch>enable
  • Switch#configure terminal
  • Switch(config)#interface fa 0/11
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/12
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/13
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/14
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#interface fa 0/15
  • Switch(config-if)#switchport access vlan 200
  • Switch(config-if)#exit
  • Switch(config)#exit
  • Switch#sh vlan

Configurasi Router

Router>enable

  • Router#configure terminal
  • Router(config)#interface fa 0/0.100
  • Router(config-subif)#encapsulation dot1q 100
  • Router(config-subif)#ip address 172.16.10.254 255.255.0.0
  • Router(config-subif)#exit
  • Router#configure terminal
  • Router(config)#interface fa 0/0.200
  • Router(config-subif)#encapsulation dot1q 200
  • Router(config-subif)#ip address 192.168.1.254 255.255.255.0
  • Router(config-subif)#exit
  • Router(config)#interface fa 0/0
  • Router(config)#no shutdown

Configurasi Swicth [Trunk]

Switch>enable

  • Switch#configure terminal
  • Switch(config)#interface fa 0/24
  • Switch(config)#switchport mode trunk
  • Switch(config)#exit

Hasil Cek Koneksi

Advertisements
Standard
./dev/sda /tmp/backtrack, Google.dork, Networking, Ppentest

Brute Force

Mendengar istilah ini waktu pertama kali terus terang saya langsung tertawa geli horor dan teringat salah satu tokoh antagonis kartun Popeye, yaitu si jahat Brutus thea euy.

Brute force attack atau dalam bahasa Indonesia disebut juga dengan Serangan brute force ini adalah sebuah teknik serangan terhadap sebuah sistem keamanan komputer yang menggunakan percobaan terhadap semua kunci password yang memungkinkan atau istilah gampangnya mungkin menggunakan Random password/ password acak. Pendekatan ini pada awalnya merujuk pada sebuah program komputer yang mengandalkan kekuatan pemrosesan komputer dibandingkan kecerdasan manusia. Istilah brute force sendiri dipopulerkan oleh Kenneth Thompson, dengan mottonya: “When in doubt, use brute-force” (jika ragu, gunakan brute-force).

Teknik yang paling banyak digunakan untuk memecahkan password, kunci, kode atau kombinasi. Cara kerja metode ini sangat sederhana yaitu mencoba semua kombinasi yang memungkinkan memecahkan tembok keamanan.

Sebuah password dapat dibongkar dengan menggunakan program yang disebut sebagai password cracker. Program password cracker adalah program yang mencoba membuka sebuah password yang telah terenkripsi dengan menggunakan sebuah algoritma tertentu dengan cara mencoba semua kemungkinan. Teknik ini sangatlah sederhana, tapi efektivitasnya luar biasa, dan tidak ada satu pun sistem yang aman dari serangan ini, meski teknik ini memakan waktu yang sangat lama, khususnya untuk password yang rumit.

Namun ini tidak berarti bahwa password cracker membutuhkan decrypt. Pada prakteknya, mereka kebayakan tidak melakukan itu. Umumnya, kita tidak dapat melakukan decrypt password-password yang sudah terenkripsi dengan algoritma yang kuat. Proses-proses enkripsi modern kebanyakan hanya memberikan satu jalan, di mana tidak ada proses pengembalian enkripsi. Namun, anda menggunakan tool-tool simulasi yang mempekerjakan algoritma yang sama yang digunakan untuk mengenkripsi password orisinal. Tool-tool tersebut membentuk analisa komparatif.

Program password cracker tidak lain adalah mesin-mesin ulet pintar. Ia akan mencoba kata demi kata dalam kecepatan tinggi. Mereka menganut “Azaz Keberuntungan”, dengan harapan bahwa pada kesempatan tertentu mereka akan menemukan kata atau kalimat yang cocok. Teori ini mungkin tepat mengena pada anda yang terbiasa membuat password asal-asalan. Dan memang pada kenyataannya, password-password yang baik itu lebih sulit untuk ditembus oleh program password seperti halnya password Cracker.

Saran: maka sebaiknya anda pergunakan password untuk segala sesuatu terutama untuk hal – hal yang sangat penting, semisalnya password kartu kredit anda, password Cpanel, password email, password PIN HP, dll.

Jika pada saat anda melakukan login ke Cpanel atau Email hosting anda dan menemukan pemberitahuan brute Force ini, maka segera laporkan kepada pihak berwajib Team support Webhosting anda untuk segera di cek penyelesaian solusinya.

Demikian, semoga dapat memberikan pencerahan.

Source: Wkipedia – ibolobolo.wordpress.com

Standard
Ppentest, Win Security

Pentest

PenTest secara umum merupakan singkatan dari Penetration Test… Artinya (menurut Wikipedia dengan sedikit perubahan) adalah suatu metode untuk mengevaluasi keamanan sistem komputer atau jaringan dengan mensimulasikan serangan yang mungkin terjadi dari pihak yang tidak bertanggung jawab (misalnya Black Hat Hacker ataupun kracker)…

Jadi, secara garis besar, kegiatan PenTest merupakan kegiatan yang memiliki etika yang baik, dengan keadaan yang terbuka dan dilakukan oleh para White Hat Hacker untuk mencoba masuk ke dalam sistem dengan menggunakan berbagai teknik yang mungkin dapat dilakukan / dicoba oleh para Black Hat Hacker maupun kracker… sifatnya lebih ke defensive purpose (mencoba menyerang, kemudian memberitahukan letak celah untuk diperbaiki oleh pemilik sistem yang bersangkutan)…

Di dalam PenTest, pasti akan terdengar lagi istilah PenTester… Dari namanya, pasti sudah dapat ketebak yach ini apa… yach, PenTester ini merupakan pemainnya, pemain dari kegiatan PenTest…PenTester ini biasanya White Hat Hacker… Orang-Orang yang bekerja pada suatu instansi tertentu yang berada di bawah surat perjanjian untuk tidak membocorkan informasi apapun yang ada pada kegiatan PenTest… namun, tidak menutup kemungkinan bahwa pelaku kegiatan PenTest ini bisa juga dari kalangan Black Hat ataupun Grey Hat… terkadang, ada alasan tersendiri dari suatu instansi untuk memakai tenang yang seperti ini (semua kembali kepada kebijakan masing-masing)…

Nah, menurut salah satu penyelenggara sertifikasi yang berhubungan dengan Hacking (EC – Cou***l), pada umumnya, kegiatan Hacking dilakukan melalui life cycle seperti ini:

1. Reconnaissance
–> lebih ke arah Information Gathering… Terbagi menjadi 2, ada aktif, ada pula pasif…
–> Untuk Pasif : pencarian dilakukan dengan tidak berhubungan langsung dengan target, seperti melalui InterNet…
–> Untuk Aktif : pencarian dilakukan langsung dengan berhubungan dengan target… Biasanya dikenal dengan sebutan Social Engineering… Ingat Kevin Mitnick…

2. Scanning
–> lebih ke arah vulnerability scanning… pencarian kelemahan dari sistem yang sedang dites…

3. Gaining Access
–> lebih ke arah mencoba untuk mengambil alih sistem yang sedang dites…

4. Maintaining Access
–> lebih ke arah meninggalkan jejak tersembunyi, sebagai contoh, meletakan backdoor… pastinya, seorang Attacker tidak ingin bersusah payah lagi mengambil alih sistem yang telah berhasil diterobos… Bisa saja keesokan harinya, sang administrator telah menge-patch sistemnya, sehingga Attacker tidak dapat lagi masuk lewat celah yang sama…

5. Clearing Tracks
–> Seorang Attacker pastinya tidak ingin aktivitas Hacking mereka berujung di penjara, jadi, mereka pasti menghapus jejak mereka setelah meletakan pintu masuk lewat belakang dan setelah mereka utak-atik sistem yang berhasil diterobos…

Nah, ini merupakan gambaran Hacking yang biasa dilakukan seorang Attacker… namun, untuk kegiatan PenTest resmi, biasanya hanya sampai Gaining Access… setelah berhasil mencapai tahap 3, maka pekerjaan mereka telah dinyatakan selesai untuk setiap celah yang ditemukan…

Standard